News

Blackboard and Firefox Incompatibility

7/6/2015

A new version of the Firefox browser has just been released (version 39.0). Updating to this version of the Firefox browser will prevent you from being able to get to the Faulkner State Blackboard login page. Blackboard Support has been notified and there is no known fix for this issue other than uninstalling Firefox and reinstalling an older version of the browser, or using a different browser such as Google Chrome or Internet Explorer.

Updated:  July 6, 2015

Back to News Listing